RASPBERRY PI 2 - Rainbow screen

Thread: RASPBERRY PI 2 - Rainbow screen

  1. MartinC's Avatar

    MartinC said:

    Default RASPBERRY PI 2 - Rainbow screen

    I have just setup my first Pi2 and installed rasplex, every time it turns on all I get is the rainbow screen.

    I have tried 2 images of rasplex 0.5.1 and 0.6.0, I have tried the delay command in both that people are saying fix it for them and no joy.

    All the hardware SD card, Power unit and board is all brand new, so I am not sure what to try next, does anyone have any ideas?

    Thanks
    Martin
     
  2. koola2's Avatar

    koola2 said:

    Default Re: RASPBERRY PI 2 - Rainbow screen

    Check the power unit output to ensure it is enough for the Pi2, I have had some dodgy plugs and cables recently that didn't send enough power to the device.
     
  3. crazyal's Avatar

    crazyal said:

    Default Re: RASPBERRY PI 2 - Rainbow screen

    Quote Originally Posted by koola2 View Post
    Check the power unit output to ensure it is enough for the Pi2, I have had some dodgy plugs and cables recently that didn't send enough power to the device.
    What he said. It will be the power supply. I normally use a wall charger that has a USB port and plug the cable into that - also I have found my TV has enough power to power the Pi.
     
  4. MartinC's Avatar

    MartinC said:

    Default Re: RASPBERRY PI 2 - Rainbow screen

    Thanks for the suggestions but I eventually solved it.

    it seems after re-installing the image from the installer, and double checking that pi2 was selected combined with using a great little file editor called notepad ++ to ensure the format of the config file is correct it just worked.


    one or both of them fixed it.
     
  5. blacksheep's Avatar

    blacksheep said:

    Default Re: RASPBERRY PI 2 - Rainbow screen

    Notepad++ is great - highly reccomend it on a windows box. Obviously vim on Linux - plenty of configurations for coding highlighting etc.