RDP & Shutdown (xp) - cuse my French!

Thread: RDP & Shutdown (xp) - cuse my French!

  1. MsDG's Avatar

    MsDG said:

    Default RDP & Shutdown (xp) - cuse my French!

    I have setup a XP PC purely for downloading stuff. It has no monitor, keyboard or Mouse and is purely controlled by RDP from another PC.

    However, this thing about shutting down the PC is really pissing me off now. I wished all the anti-shutdown stuff would really just fuck off!

    I have sussed how to shutdown the PC via RDP by creating a icon with a force shutdown command line.

    However, I use flashget for my downloads. This has a "shutdown when all downloads are complete" option. However, when I set up a download and log off and leave the PC running, I come back hours later to the PC still switched on! When I log on, I get a windows message saying something like "If you shutdown, no one will be able to log on" etc

    How can I just get the thing to stop fucking around and just shutdown with no stupid fucking questions?

    Any ideas?
     
  2. Mr.James's Avatar

    Mr.James said:

    Default Re: RDP & Shutdown (xp) - cuse my French!

    how are you RDP'ing to the box? are you running remote desktop from the shortcut link on your start menu or are you launching it from a saved .rdp file?

    i'm thinking it might be down to you starting a second session on the box (kinda like using the 'switch user' feature) rather than connecting to an already open session or firing up a 'console' or 'admin' session.

    i think that because it's detecting two sessions on the computer it's giving you this prompt rather than just switching off.

    try changing the shortcut to %systemroot%\system32\mstsc.exe /admin for RDP client 6 or
    %SystemRoot%\system32\mstsc.exe - console for previous versions.

    if you are using a saved .rdp file, open it in notepad and add the line connecttoconsole;i;1
    Last edited by Mr.James; 26th November 2008 at 08:23 PM.
     
  3. MsDG's Avatar

    MsDG said:

    Default Re: RDP & Shutdown (xp) - cuse my French!

    Thanks... but made no difference (tried the RDP 6 admin thang)

    Here is what happens (step by step)

    1) Turn on Server (XP)
    2) Turn on my PC (Vista)
    3) Logon to my Vista PC
    4) Start a RDP session on Vista on connect to Server

    Next bit done over RDP session...
    5) Logon to server XP (entering userid and password)
    6) Straight away notice that the server now only has options of (disconnect and logoff) on the start menu

    (where as if you login directly to the server using its own mouse and keyboard you will get normal settings with shutdown option using same logon?)

    7) Start Flashget and start downloads

    8 )Close RDP session, shutdown Vista PC and leave the server running.

    9) Come back hours later to find server still active

    10) Start up Vista PC, start up RDP seesion only to find the following message on the XP Server.....

    "if you shutdown this remote computer, no one can use it until someone at the remote location manually restarts it. Do you want to continue? yes/no"
     
  4. tom999's Avatar

    tom999 said:

    Default Re: RDP & Shutdown (xp) - cuse my French!

    May not be the answer but a workaround could be to use something like logmein.com which logs onto the actual account already open not creating another "user logon"
     
  5. Mr.James's Avatar

    Mr.James said:

    Default Re: RDP & Shutdown (xp) - cuse my French!

    Can you download a copy of uTorrent and stick it on there as a quick test?

    Set uTorrent to auto shutdown when downloads complete. Then download some small random torrent and see if uTorrent has the same problem popping up when it tries to shut the computer down. Let me know me what you get.
     
  6. Mr.James's Avatar

    Mr.James said:

    Default Re: RDP & Shutdown (xp) - cuse my French!

    Another thing to try is disabling multiple sessions on the XP server.

    run regedit.exe and browse to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

    Double click AllowMultipleTSSessions and set it to 0. Restart the box and give it another go.