Poorly Xbox360

Thread: Poorly Xbox360

  1. GedR's Avatar

    GedR said:

    Xbox 360 Poorly Xbox360

    OK Here's the Story-

    Got the lad a pre-modded 360 about 18 months ago from a place in Oldham and it's been faultless ever since - Until Today. The console starts up OK from cold and loads any of his games but after about 5 or 10 minutes freezes solid. There's a lot of corruption of the video in the form of vertical rows of small white blocks, the sounds also stops so it's not just the video chip. Also no red rings on the circular display.
    If the system is turned off then on again it does the same thing very quickly.
    Overheating methinks, so I pulled the thing apart and removed the two coolers, cleaned the surfaces and applied arctic silver then put the lot back together. Never done this before so made me sweat a bit. Unfortunately it hasn't made the slightest bit of difference. Still does exactly the same.

    I'm in Chester so can anyone recomend someone that can either sort this out or is there anyone local that could sort out a new Xbox preferably within reasonable driving distance. The poor lad is gutted so I'm hoping to get this sorted ASAP.

    Here's hoping ..... GedR
    Last edited by {{909}}; 26th December 2008 at 09:07 AM.
     
  2. bbshark's Avatar

    bbshark said:

    Default Re: Poorly Xbox360

    ring ms and tell them its 3rl. thats whats coming anyway.
    bbshark. The Member with the first ever DF Fine

    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
     
  3. rids's Avatar

    rids said:

    Default Re: Poorly Xbox360

    sounds like the heat is flexing the bored just alittle and lifting a dogy soldier joint the rrod kit shuld hold them together tight enoth but if you want do an xclamp remove (if you havent already)
    Quote Originally Posted by GedR View Post
    OK Here's the Story-

    Got the lad a pre-modded 360 about 18 months ago from a place in Oldham and it's been faultless ever since - Until Today. The console starts up OK from cold and loads any of his games but after about 5 or 10 minutes freezes solid. There's a lot of corruption of the video in the form of vertical rows of small white blocks, the sounds also stops so it's not just the video chip. Also no red rings on the circular display.
    If the system is turned off then on again it does the same thing very quickly.
    Overheating methinks, so I pulled the thing apart and removed the two coolers, cleaned the surfaces and applied arctic silver then put the lot back together. Never done this before so made me sweat a bit. Unfortunately it hasn't made the slightest bit of difference. Still does exactly the same.

    I'm in Chester so can anyone recomend someone that can either sort this out or is there anyone local that could sort out a new Xbox preferably within reasonable driving distance. The poor lad is gutted so I'm hoping to get this sorted ASAP.

    Here's hoping ..... GedR
     
  4. Anakin's Avatar

    Anakin said:

    Default Re: Poorly Xbox360

    ive got the same problem. I ordered the xclamp and im gonna give that ago.
     
  5. MODDIGI's Avatar

    MODDIGI said:

    Default Re: Poorly Xbox360

    I've had the exact same problem with a couple of consoles. Total freeze, graphics corruption and no ROD. X-Clamp fixed both and one has been running for over a year without problems
     
  6. GedR's Avatar

    GedR said:

    Default Re: Poorly Xbox360

    Thanks for quick replies. Looks like it's a no-brainer for the cost of the X-Clamp.
    Fingers crossed, eh !

    GedR
     
  7. fevernova's Avatar

    fevernova said:

    Default Re: Poorly Xbox360

    thats a e74 error 1 read light, needs new heatskin and a xclamp mod on the gpu