Close

Results 1 to 2 of 2

Thread: X-ecuter

  1. #1
    Guest 's Avatar

    Default X-ecuter

    I finally received my X-ecuter chip yesterday. I installed it but could not get the latest version of EvoX to run. I then tried the ******** NoPC ISO and it worked perfectly. I have changed my drive to an 80GB HDD and have begun copying my games to the hard drive. I am happy that I waited. I guess patience is a virtue.

  2. #2
    DF PiMP Mookie's Avatar
    Join Date
    Dec 2000
    Location
    United Kingdom
    Posts
    363
    Thanks
    0
    Thanked:        2
    Karma Level
    276

    Default

    X-Ecutor mod worked fine for SG and TZone (ADR) and they are running latest EVO X bios and 120gig (5200rpm) drives.

    Both did notice that they hadn't used enough solder on the contact points at first though.

Similar Threads

  1. x-ecuter 2
    By TAR in forum Microsoft Consoles
    Replies: 3
    Last Post: 24th December 2002, 09:42 PM
  2. X-ecuter
    By TAR in forum Microsoft Consoles
    Replies: 4
    Last Post: 27th November 2002, 12:45 PM
  3. X-ecuter does it again
    By sonar in forum Microsoft Consoles
    Replies: 0
    Last Post: 21st November 2002, 01:32 AM
  4. X-ecuter 2
    By sonar in forum Microsoft Consoles
    Replies: 19
    Last Post: 3rd November 2002, 07:34 AM
  5. X-ecuter
    By rishy in forum Microsoft Consoles
    Replies: 5
    Last Post: 2nd October 2002, 04:43 PM

Social Networking Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •