after getting a milestone this morning, I've been unable to send mms from it

I'm on o2 contract simplicity.

and after 2.5 hours of trwling web i've found setting that work, so thought i'd share here incase anyone else has any probs.

1. Delete all of your existing APN settings and restart your phone.
2. Input these APN settings:

NAME: O2 UK Postpay
APN: wap.o2.co.uk
PROXY: <Not set>
PORT: <Not set>
USERNAME: O2wap
PASSWORD: password
SERVER: [Only registered and activated users can see links. ]
MMSC: [Only registered and activated users can see links. ]
MMS: PROXY 193.113.200.195
MMS: PORT 8080
MCC: 234
MNC: 10
APN TYPE: <Not set>

Press 'Menu' and select 'Save'.

3. Now restart phone again.
4. Switch on 'Mobile Network' and test it. Should work perfectly!!!

hope this helps