Server moved into other room. No longer able to Remote Desktop.

Thread: Server moved into other room. No longer able to Remote Desktop.

  1. DejaVu's Avatar

    DejaVu said:

    Default Server moved into other room. No longer able to Remote Desktop.

    I've moved my server into another room of the house (a colder area of the house).

    I've also replaced my old HH4 for my HH5. All is well, internet works on both.
    The network share folders are accessible from both systems. Nothing else has changed.

    I can Ping the server from my main PC perfectly.

    I can no longer Remote Desktop it from my PC. Weirdness? Any ideas what's gone wrong lads?
    HH5 setting I've missed perhaps?

     
  2. Undertaker's Avatar

    Undertaker said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    guess its a bit obvious but have you done another reboot? LOL

    as you say you changed the home hub so its most probably that
     
  3. Over Carl's Avatar

    Over Carl said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    How are you accessing RDP? Internal IP address (192.168.xx.xx), internal hostname (myserver), external IP (router IP), or internet hostname (myserver.dyndnsprovider.com)

    I'm guessing you are using external name or IP and the new router doesn't support or isn't configured for hairpin nat, or your dynamic DNS isn't working. Or if it's internal hostname check your DNS settings.



    If it's internal IP, put everything back how it was and pretend this didn't happen
     
  4. Undertaker's Avatar

    Undertaker said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    OC, i am guessing its all local

    Deja - check if subnet hasn't changed, if using internally then there shouldnt be a need to port forward. Maybe you got a fixed IP address and subnet on your main pc?
     
  5. DejaVu's Avatar

    DejaVu said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    Quote Originally Posted by Undertaker View Post
    guess its a bit obvious but have you done another reboot?
    Yup, rebooted both main PC and server.

    Quote Originally Posted by Over carl View Post
    How are you accessing RDP? Internal IP address (192.168.xx.xx), internal hostname (myserver), external IP (router IP), or internet hostname (myserver.dyndnsprovider.com)

    I'm guessing you are using external name or IP and the new router doesn't support or isn't configured for hairpin nat, or your dynamic DNS isn't working.
    Tried accessing via both Fixed IP Address and hostname.

    Have googled and found this - [Only registered and activated users can see links. ]
    BT's support forum is an absolute waste of time. Blind leading the blind!

    Further googling and 'Public' Networks on the server for RDP was blocked as standard.
    The network used to be Private til I added the HH5. Now it's Public on the server?!? Ticked the box in the firewall and all came back to life.

    BT Routers are the shittest of the shit and now think its high time I collared a Draytek Vigor.

     
  6. Over Carl's Avatar

    Over Carl said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    Internal (LAN) IP/hostname or external (WAN) IP/hostname?


    Edit: Sorry didn't see you fixed it.



    It's not the HH's fault. MS decided since Win7 that if the MAC address of your default gateway changes, it decides it's a new network. This really pissed me off when I set up a high availability pair of routers and when it failed gracefully to the backup router, all win7/server 08 boxes moaned about a new network.
     
  7. DejaVu's Avatar

    DejaVu said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    Yeah. Kinda sorted it. For some reason Windows reporting it as a Public Network. Not sure why, but can live with it for now til something nasty happens.

     
  8. beerman's Avatar

    beerman said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    Quote Originally Posted by DejaVu View Post
    Yeah. Kinda sorted it. For some reason Windows reporting it as a Public Network. Not sure why, but can live with it for now til something nasty happens.
    When you first selected the private network there was an option to treat all other networks as public. You probably ticked this option.
     
  9. Tim.Lad's Avatar

    Tim.Lad said:

    Default Re: Server moved into other room. No longer able to Remote Desktop.

    I can not remember when this was added think it may have been in 2008 server but the system detects if the default gateway changes maybe with upnp then sets up a new network connection with default network location some features get turned off is rdp
    VIP WOOP !