Aprillia rs125 2001

Thread: Aprillia rs125 2001

  1. big3card's Avatar

    big3card said:

    Default Aprillia rs125 2001

    Hi to all ... looking for some advise on my rs125 it being a cnut, it will run fine with the choke on and pull ok but when I turn the choke off it hard to pull away with no power, as if the bikes struggling for fuel but fuel flow to the carb is good and the carb is all clean as well as filters and jets

    I've tried adjusting the air mixture and this has no apparent effect on the running of the bike ... so im at the conclusion the piston rings are worn, I've only had this bike for 3 months and has been like this since, just to add the carb is delorto phpbh28.

    Any thoughts appreciated b3.
     
  2. plug1's Avatar

    plug1 said:

    Default Re: Aprillia rs125 2001

    Check all the gaskets and seals on the carb , does it run worse without the air filter ?
     
  3. big3card's Avatar

    big3card said:

    Default Re: Aprillia rs125 2001

    It runs exactly the same without the air filter on, so far on the the carb I've checked the fuel flow from the tank and its flowing, stripped n checked the jets they were clear but I cleaned again, next the fuel-in tap in the bowel itself, all removed and checked and work fine ,the float is floating!, I've checked the fuel level in the bowl and its filling perfectly.

    I've inspected the carb manifold for air seeping and its sealed and clean, the reed valves are operating as should ,im just making sure I haven't missed any thing before I remove the head for a ring/barrel inspection cheers
    Last edited by big3card; 2nd April 2015 at 09:21 PM.
     
  4. plug1's Avatar

    plug1 said:

    Default Re: Aprillia rs125 2001

    You've done all you could do by the sounds of it mate , if it's not the mixture then you will need to pull the head .
     
  5. big3card's Avatar

    big3card said:

    Default Re: Aprillia rs125 2001

    Cheers Plug, head is being pulled thanks ... ill post my findings .b3