MacBook Pro and BT Router

Thread: MacBook Pro and BT Router

  1. AspectUK's Avatar

    AspectUK said:

    Default MacBook Pro and BT Router

    OK this is really boiling my piss right now.

    Ever since I moved house and changed provider to BT Infinity 2 I've had a problem connecting to the wifi router.
    Every time I shut the lid, the next time I open it up it tries to connect to the router but brings up the enter password box.
    I enter the password but it then says: "Invalid Password"

    I keep pressing the Connect button and sometimes after about 10 attempts it actually connects.
    Other times it simply refuses so I go to System Preferences > Network and remove it from the list and then add it again and go through the same enter password routine until maybe eventually it connects.
    Sometimes I even try restarting both the MacBook and the Router but same issue

    Once connected it's absolutely fine.

    My OpenBox connects fine, my Android phone connects fine, my wife's Chromebook connects fine as does her and the daughters iPhone, it just my MacBook thats having an issue.

    Anyone had this before?

    I'm using Yosemite 10.10.5
     
  2. consoles's Avatar

    consoles said:

    Default Re: MacBook Pro and BT Router

    might be a driver issue, remove the driver and reinstall latest
     
  3. muttleymacclad's Avatar

    muttleymacclad said:

    Default Re: MacBook Pro and BT Router

    I've had a similar issue but with a pc laptop and virgin superhub.
    There was a setting on the router that allowed devices connected to the 2ghz to get speeds up to 300mb however it was unstable. I set it back to 54mbs and this solved the problem.

    May be worth looking to see if there's a similar setting on the BT hub.

    Sent from my D5503 using Tapatalk
     
  4. andmor's Avatar

    andmor said:

    Default Re: MacBook Pro and BT Router

    sounds like this person had the same issue..

    [Only registered and activated users can see links. ]
     
  5. TIN CAN's Avatar

    TIN CAN said:

    Default Re: MacBook Pro and BT Router

    I had this and ended up turning off the 5ghz band sorted my issue
     iPhone 6 baby...
     iMac 24", 2.4Ghz, 500GB, 4GB RAM
     Macbook Pro 2.4Ghz, 250GB, 4GB RAM
     
  6. AspectUK's Avatar

    AspectUK said:

    Default Re: MacBook Pro and BT Router

    I think it's sorted now. Renamed the SSID of the 5Ghz frequency.
    Was so infuriating. Basically my MacBook doesn't understand the 5Ghz frequency but still tries to connect to it??

    Grrr .. hopefully problem free till I remember my Apple ID and upgrade to El Capitan
     
  7. Squizza's Avatar

    Squizza said:

    Default Re: MacBook Pro and BT Router

    I remember having similar issues.

    My solution was to buy an Airport Extreme to replace the wifi from the Home Hub.
    So, interweb comess into the Home Hub. then a cable to the Airport Extreme and I then have a few Airport Express' dotted around the house to extend the network, some wired for a better signal.

    Expensive solution, but as the house is all Apple it made sense. I always buy the stuff from the Apple Refurb Store to save a bit of coin.